Error in Skylight Workflow Sync Tool

Hey guys,

I am trying to run through the steps mentioned in the documentation here.

But it gives me this error in the logs life.

2021-03-10 08:49:28,598 [8 ] ERROR Skylight.DataConnector.SyncWorkflow.Managers.SyncManager - ERROR: Unexpected character encountered while parsing value: <. Path ‘’, line 0, position 0.

I am not sure what this error means. Do you guys know what I should do?

Hi Samvid,

There are a few things you might need to look at. First could you check the path selected and the folder names below that path to see if there are any special characters? If you pasted the path there could you use the “Select Directory” button and see if that help with the error?

Fell free to attach a picture of your selection in the tool as well.

Could you also tell us if your OS is set to a language other than English. It should not matter but still something that is worth looking at.

Hey thanks for the response.

I don’t think I have any special characters. I did use the ‘Select Directory’ and it still gave me the same error.


Yup OS language is set to English.

Here is the log.

Hi,

Founds the issue, look at the Skylight Web URL section in the documentation. You have the wrong information in the Skylight Web URL section.

It should be https://skylight.upskill.io as you are on a USA domain.

Thank you!

Alright. I got a new error now.

2021-03-17 09:03:39,796 [5 ] ERROR Skylight.DataConnector.SyncWorkflow.Managers.SyncManager - ERROR: Group [Workflow Template Users] not found in Skylight

I added a user group in the application permissions but it still creates the same error.

Hi,

Can you check if the Group has been modified in the Workflow Sheet? The Group that you added to the Application Permissions should be updated on the Info tab of the sheet.

Example:

Group Name says: Workflow Template Users
Should I change it to something else?

I changed it to my group name and now it says synced but I am not seeing it in the application.

Also do you know how can I delete an application?

Hi Samvid,

Once your application is configured with the group added as a user role and published. Your imported workflow will show up on the Skylight client, as long as you are signed in as a user for that application.

if you run the web client and don’t see the workflow you imported. please provide us with more information on the setup with screen captures of the application and also the logs from the import.

For your second question I will address that in a different post.